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1 WhatlIs OPC?

OPC (OLE for Process Control) is a standard designed for real-time data exchange between a
software application and process control devices such as PLCs. OPC defines an interface
independent of the device type. As a result, the end user is almost not limited in the choice of
hardware and software for his/her application. The only requirement is OPC compatibility.

There are two kinds of OPC components: OPC client and OPC server.

An OPC client is a program that gets (reads) the data from an OPC server for further
processing. The typical examples are MMI and SCADA/HMI systems.

An OPC server is a program that provides data to OPC clients. It is usually designed to read
data from a specific hardware device. An OPC client communicates with an OPC server
through a strictly defined interface. As a result, any OPC client can communicate to any OPC
server regardless of the type of device for which the server has been created.

The OPC standard is developed by the OPC Foundation organization grouping hundreds of
software companies and hardware manufacturers worldwide. New features are continuously
added to keep the standard up to date.

A tutorial demonstrating the basic aspects of the OPC standard is available on the website of
Matrikon, a renowned OPC product developer company.
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n Data Transfer Principle

1.1 Data Transfer Principle

OPC server is usually a MS Windows application that communicates with a HW device (PLC)
via device-specific protocol - server can communicate with HW device e.g. via serial line. Data
acquired from HW device is provided via unified interface to other applications - OPC clients.
OPC standard states, that several OPC clients (even from different companies) can connect to
an OPC server concurrently. Most OPC clients (like Reliance) can connect to several OPC
servers simultaneously.
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OPC Server Configuration n

1.2 OPC Server Configuration

OPC server is usually not provided only by HW device manufacturer, but also by other
companies, so several OPC servers can exist for a device. The list of OPC servers for a specific
device can be located on the OPC Foundation WWW pages.

After successful installation of an OPC server so called configuration have to be created and
registered. To create the configuration means to define the list of devices connected to the
OPC server, to define parameters of these connections and to define the list of tags (OPC
items) that should be read from the device. Configuration have to be saved and registered, so
it can be loaded immediately after OPC servers starts.

Note: OPC server installation, start and configuration is specific for every OPC server GUI (it is
OPC server producer specific).
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2 Reliance and OPC

Reliance is a modern SCADA/HMI (Supervisory Control And Data Acquisition) system
designed for monitoring and controlling industrial processes. One of many features of the
Reliance system is in-build OPC interface - Reliance is an OPC client.

The goal of this document is to describe steps required to create a simple visualization project
(application) connected to an OPC server.

Creating a New Visualization Project

Creating a New OPC Device

Connecting New Device in the Project Structure Manager
Adding a Display Component to a Visualization Window
Creating a Link to the Display Component

Running the Project in a Runtime Software

For detailed information about the Reliance system, please visit www.reliance.cz.
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Creating a New Visualization Project “

2.1 Creating a New Visualization Project

To create new visualization project, start the development environment Reliance 4 Design and
select the File > New Project command.

« Reliance 4 Design - Project

"File’ Edit View Managers Project Tools Window Help

1 Mew Project... |
1" Open Project... Ctrl+0 |

Restore Project from Backup...

Close Project

Mew Window...

Mew Window Template..,

Save Window Ctrl+5
Save All Windows

Close Window Ctrl+F4
Close All Windows

1 4 K8 Projects\Projectl\Projectl.rpd

25 B e e lre e AirCondition.rpd
ERAL B T

G TR, o, O, i

Exit

File menu
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n Creating a New Visualization Project

Enter a name of the new project (e.g. OPC) on the Project name and location page of the
Create New Project Wizard. Change the default project directory if it is required and Finish the
wizard (on the next pages keep default settings).

Create Mew Project Wizard ks

Project name and location EI

Choose a name and location for your project.

Everny vizualization project iz stored in files organized in a directary structure. One of the files
has an "rpd’ extenzion and iz called the main file of a project. k2 name iz generated bazed on
the name that vau enter for pour visualization project. The file name can contain only characters
WUE A Y and

Project] Projectl.rpd

Chooze the directary where pour project should be stared.

3 | O\ Eslspnadmuiinguin S mne

Mote.: & new folder for the project will be created in the specified directomn. The default
directary far visualization projects can be configured through the Environment Options dialog.

| ]

Create New Project Wizard
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Creating a New Visualization Project

After a new project is successfully created, Create New Window Wizard automatically starts to
assist in creation of the visualization window. Visualization window contains graphical
elements (so called components), which define custom graphical user interface. On the first
page of the wizard enter the Name and the Title of new window (or keep the default settings).
Finish the wizard (on following pages keep default settings).

Basic information i
Enter a name and title far the wisualization windaw,

Enter a name for the visualization window, The name must be unigue within the project.
Window

E nter a title for the vizualization window.
Window

Create New Window Wizard
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n Creating a New OPC Device

2.2 Creating a New OPC Device

Open Device manager via Managers > Device manager. Add a new OPC device with the New
Device command (in the Select Device Type dialog window choose OPC). Select the device
object in the upper left pane (in the tree) and configure the properties of the OPC device (on
the left side of the window). On the Basic page define the OPC server identifier (OPC server
Prog ID). The identifier can be entered either manually, or selected from the list of OPC servers
installed on your system (after clicking the OPC icon).

i hl
& Device Manager —— [=]=E] =]
1 §m ‘54 » Eli ‘Eq, ? e fE ) wo | Basic | Advanced | Information
=} (0] Devices Mame
I + f System opPci i
=+ ¥ 9 oPc1
(& Tags Alias

(@] Alarms/Events

Miscellaneous
OPC server Prag D

9F | X |TECO.DAZ

OPC server GUID
{A42F19F4-508B- 4R ittt g

[™] Impart tags from remate computer

[ Automatically generate OPC ltemlD for nested tags

Llelingibe
Mame

& Select OPC Server l = | B i)
(& Tags
@) ArmsfEvents | | OPC Server DA10  DAZ2D I
= j Local |
@ Teco OPC Server Yes
L. Remate
1
[ Ok ] [ Cancel ]
)
D=1 Devices\DPCT [ 0k || oese || Savea
L - !

Device Manager - Select OPC server dialog
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In the tree select the Tags folder of the OPC1 devic

Creating a New OPC Device u

e. Create a new OPC group via the New

OPC Group command (from toolbar or local menu). You can change its nhame for example to
OPC. Select the newly created folder object and via the Import from OPC Server command

import tags (OPC Items) from the OPC server - install
to provide the list of tags defined in its configuration.

ed OPC server should automatically start

& Device Manager m—— E@g
il B G 3 04 siyam EER 3 Ey ¥ | Basic | Information
= Devices Mame
H = cg: oFC Group1 i
=1 [ Tags
= % Alias
@ et e
@ = ¥
@ i Export and import in C5¥ format
]
; ’ Export ] ’ E xpaort [Unicode] ] ’ Irnpaork ]
§ s
¥ @ bupeat BnpeRileoats | ;
8 O st Budiosiih mport of tags
(&) AarmsiEvents [ Impart from OPC Server l
+- iy System
[ Impert from OPC CSY |
[ Export ta DPC C5W |
OPC group properties
M T Add
ame bES ress Update interval [ms) Dead band [%)
Bool
500 = 0 =
Word (16... = = I
Bool i
] Word (16... OPC group state
] Word (16... () Inactive
g Eodl @ Active
] Bool ST G N S §
() Tag controlled
101 Deviees\DPCT\T agstGroupT ook J[ oo J[  sowear |
— ’

OPC group properties
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Creating a New OPC Device

The Import Tags from OPC server dialog window is divided into a left pane with Reliance
defined objects and the right pane with OPC server defined objects. Drag and drop objects
from right to left pane with a mouse to import the tags form the OPC server.

& Import Tags from OPC Server b E@Iﬂw
Sl D B X (| B B2 Empty/Defau + RAW + 7
OPC Device OPC Server
Mame a Type Update interval || Mame WValue Type Rt
= 9% OFCI =9 TECO.DA? OFC... -
B (& Tags Bl @ Nkt Cmsudks Bool R N
B @ Group] 500 B @ ko word .. RW
o ] Bool E @ Bod AW
@ werd (15 ) @ of word .. RW
@ Bool W @ word... Rw
g ... Word[16b] E @ Boo R
’ word (16 b) w o Bod R
s .. Bool B @ % Lorgl... Rw
i L8 @ YedesiSwesars. Bool B @ ¥ Longl.. Rw
B Longl.. Rw
-- % Armay . RWw
-- s % Longl... R E
B @ Longl... Fw'
" ¢k Longl... Rw
Boo Date.. FWw
B¢ % Small.. Rw
H@ ¥ Bool  RWw
B @ word... R/
\ B¢ & Bool  RWw
| o @ word... RW
B @ word... Rw
B Bool  Rw
B9 & Bool  RWw b
B @ Longl... Fw
[P T Longl... Fw
B @ Eih Longl... Fw
-- % rstaBuffer Armay ... Bw il
m P N e bl 1 mumml =YX}
[ Ok J ’ Cancel

Import Tags from OPC Server dialog
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Connecting a New Device in the Project Structure Manager

2.3 Connecting a New Device in the Project Structure Manager

Each object that should be accessed on runtime have to be connected to a computer first.
Connecting an object to a computer means to add an object to a specific folder in the Project
Structure Manager under required computer (configuration). After the changes made in the
Device Manager are saved, the user is asked if newly created object should be connected to
the computer. If Yes is chosen, Project Structure Manager is automatically opened and OPC
device is added to the Devices folder under the PC1 computer. If No is chosen, object is not
connected to any computer and it have to be connected later manually.

Before a device is connected, first open the Project Structure Manager (Managers > Project
Structure Manager) and in the left pane (the tree) select the Devices folder. To manually
connect a device to a computer chose the Connect Devices command from the local menu (or
Connect Objects from toolbar).
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Connecting a New Device in the Project Structure Manager

. s
s s I =
S Wi EE B T 4% - Sa 4 Gy x| Basic | MEM file | Information
= %% Control Areas Enable
E}ﬁ Contral Areal .
i | Ol
SR riine
- (3 Devices Active channel chaoice
B Q Autamatic
% Channell Tag-controlled [Index]
- [ Data Tables
- [l Trends [ Index | ; |)< |_ |
- [ Reports
-~ [Zl Custom Reports [ status | \ |>\ |— |
- [ Recipes
[ Seripts Channel list
- [i5 users
- [25 Printers S & Order
-~ (4] Modems E‘, Channel
|1} |3 communication Drivers
@ Server Connection Groups i
|
g Channel
4 n | »
|
D=1 Cortral Arzash\Contol Areal \PC1ADevices\OPCT Lok J{iBose J[  savem |

Project Structure Manager
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Connecting a New Device in the Project Structure Manager

In the Select Device dialog window chose OPC1 device and confirm.

& Select Device

X

o |
a 5
5]

pEY

£ ‘u’iew - Manager

[tern ligt

]9

|| concel |

D=1 OPC1

Select Device dialog

Close Project Structure Manager with the OK button to save the changes.
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Adding a Display Component to a Visualization Window

2.4 Adding a Display Component to a Visualization Window

The Display component is located in the component palette (to the right from the main menu)
on the Standard tab. Select the Display component in the component palette and click into
the visualization window area to add the component.

Window Help Standard | Teco | Johnson Controls | Sauter | Vectors | Co
8 @z Bacsege BNESAAEBRVTS =
P i I & T DG &

F‘H‘H’indcwl ~ Windowl [ o

Adding the Display component to a visualization window
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2.5 Creating a Link to the Display Component

Creating a Link to the Display Component

Newly added display component have to be linked to a tag to show a value. Open the Display
Properties dialog (e.g. double click on the component or select the command from the

component's Local menu).

.‘\\ — =
51
=

& Windowl - Windowl

Align Position to Grid

Align Size to Grid

Lock Ctri+L
Save Window Ctrl+5
Duplicate Window...

Close Window

Component Properties... Alt+Enter

Component's Local Menu
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Creating a Link to the Display Component

On the Functions tab enter tag's full name in the Link to tag field. Tag name can be also
selected via Select Tag dialog (dialog is shown after the icon on the left is clicked).

| Bazic | Alignment | Dyraric | kenu | Scripteddctions | Securit_l,l| Functions | Static | Eng. units|

Link to tag

Test value Q.00

Limits
[T] High warning [T] High critical

Walle

Walle

B ackground

Background

[7] Low warning [7] Low critical

YWalue Walue

Background B ackground .

k. “ Cancel ] Apply

Display Properties
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Creating a Link to the Display Component

In the dialog window select the tag imported from the OPC server (see chapter Creating a new
OPC device) and confirm the dialog with the OK button.

I & Select Tag . X
F T % @Wm - Manager C -

Kotelnal.Cerpadio

Tag Type Address

ID=1 OPC1MGroup! ‘Wasesd Eaise

Select Tag dialog
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Running the Project in a Runtime Software

2.6 Running the Project in a Runtime Software

To start the project in the runtime software select the > Project > Start command from the
main menu (or press F9 ). The type of started runtime software depends on the licence and on
the settings in the Project > Options > Runtime (View, Control or Control Server).

Managers | Project | Tools Window Help

Run Fa
Create Shortcut...

Register As Service..,
Perform Diagnostics...

Backup...

Starting the runtime software

The display component shows the real-time value of the OPC tag.

F:

¢ Reliance 4 Control Server - OPC - PC1

File Help

10

Tag value displayed in the Display
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