Reliance 4

FIRST STEPS
Reliance 4

FIRST STEPS
# Table of Contents

1. Introduction ...................................................................................................................... 1
2. Reliance 4 modules ........................................................................................................... 2
3. Reliance 4 Design ............................................................................................................. 3
   3.1 Creating a new project ................................................................................................. 3
   3.2 Creating a new window ............................................................................................... 5
   3.3 Device Manager – devices, tags and other objects ..................................................... 7
   3.4 Other managers – data tables, trends and other objects ......................................... 9
   3.5 Project Structure Manager – Control areas and Computers .................................... 12
   3.6 Designing windows .................................................................................................... 13
   3.7 Running a project ....................................................................................................... 15
4. Example ............................................................................................................................ 17
   4.1 Creating a new project ............................................................................................... 17
   4.2 Adding devices and tags ........................................................................................... 17
   4.3 Component position and properties ......................................................................... 18
   4.4 Testing the project ..................................................................................................... 19
1 Introduction

The goal of this manual is to introduce a new user to basic functions of Reliance 4 Design – the development environment of Relance 4 SCADA/HMI system (Supervisory Control And Data Acquisition/Human Machine Interface). The user is introduced to steps required to create a new project, define devices and tags, design a visualization window and run the project.
2 Reliance 4 modules

The *Reliance 4 deployment example* illustrates typical examples of using particular modules and connections among them. *Reliance 4 Design* is the development environment for creating visualization projects. The module most commonly used at the end-user site is *Reliance 4 Control* which has all functions needed for projects operated on a single computer. Projects with multiple computers have to use *Reliance 4 Control Server* (or Server which runs as a Windows service) which allows for providing other *Reliance 4* modules with data. *Reliance 4 View* is only intended to view information, with no means to write data into physical devices (PLCs).
3 Reliance 4 Design

3.1 Creating a new project

The first window shown after start of the Reliance 4 Design development environment is Welcome Screen. Choose the Create New Project item to start the Create New Project Wizard which will guide you through the process of creating a new visualization project and its basic configuration.
In the first step of the wizard, enter a name for your project. The subfolder and file names are automatically generated based on the project name.

Create New Project Wizard – Project name and location

In further steps of the wizard, you can activate project encryption and enter a comment about the project. In the last step, choose the **Perform** command to complete the wizard.
The **Create New Project Wizard** can be also started by choosing the > *File > New Project* command.

![File – New Project](image)

### 3.2 Creating a new window

To create a new visualization window, choose the *New Window* command available in the **Window Manager**'s toolbar and popup menu. This starts the **Create New Window Wizard** which will guide you through the process of creating a new window and its basic configuration. The **Create New Window Wizard** is also started automatically upon the completion of the **Create New Project Wizard**.

In the first step of the wizard, enter a name and title for the new window. A name is a unique identifier of the window within the project. A title is the text to be displayed in the window's title bar.
Creating a new window

In the second step of the wizard, you can choose the window type. Choose the **Perform** command to create the new window.

Upon the successful creation of a new project and a window, the project can be run with the > **Project > Run** command (optionally using the *F9* key). The project runs in full-screen mode and can be closed by the > **File > Exit** command or using the *ALT + F4* key shortcut.
3.3 Device Manager – devices, tags and other objects

The **Device Manager** command is located on the > **Managers** menu. The **Device Manager** allows for defining devices, tags, alarms/events and communication zones.

In the context of **Reliance**, a **device** represents a *physical device* (e.g. PLC or other similar I/O device used for industrial automation and control) or the so-called *virtual device*. Within each **device**, you can define tags and alarms/events linked to the tags. The values of the tags can be used to generate alarms/events, can be displayed via components (graphical objects used to build a visualization), can be used to control the appearance and behavior of components, can be logged to databases, processed by scripts, etc. If a device represents a physical device, a tag represents a process variable at a specific address of the device's register. The runtime software obtains the tag data from the device's communication driver or a data server (*Reliance 4 Server* or *Reliance 4 Control Server*). Otherwise, the device’s tags only exist in the memory of the computer on which the visualization project is running and are referred to as **internal** tags.
Every visualization project contains a predefined virtual device named System. It is intended for defining private internal tags (so called system tags) which can be used in the same way as tags of other devices. System tags are especially useful e.g. for storing results of calculations performed in scripts. Unlike tags of other devices, system tags do not affect the number of data points used in a project. Therefore, any number of system tags can be defined in a project without affecting the price of the license needed for the project. However, system tag data cannot be transferred between different instances of the runtime software over a network in client/server applications.

A new object (device, tag, alarm/event, etc.) can be created by choosing a command from the popup menu of the tree structure, tool bar or by pressing the Insert key.

Upon choosing the New Device command, you need to select the device type. After creating a device, the type cannot be changed anymore. The device properties differ based on device type. A device always contains the Tags and Alarms/Events folders. In addition, some device types contain the Communication zones folder.
A new tag can only be created if an object of type Tag folder or object subordinated to this folder (e.g. tag) is selected (marked) in the tree structure. Tag properties differ based on device type. They determine e.g. address and data type, engineering units or critical and warning limits. Tags can also be imported from various formats.

A new alarm/event can only be created if an object of type Alarms/Events folder or object subordinated to this folder (e.g. alarm/event) is selected (marked) in the tree structure. Alarm/event properties determine e.g. link to a tag, triggering condition, type, access rights required for the acknowledgment and actions to be executed alarm/event start, end or acknowledgment.

A new communication zone can only be created if an object of type Communication zone folder or object subordinated to this folder (e.g. communication zone) is selected (marked) in the tree structure. Communication zone properties differ based on the device's communication protocol. Communication zones enable you to control and optimize reading data from a physical device and are only available with certain device types (Teco and Modbus). A communication zone represents a data block to be read from a physical device. Defining communication zones is optional. If zones are not defined, reading data is performed based on the "Data update interval" property of tags.

### 3.4 Other managers – data tables, trends and other objects

In addition to objects defined through the Device Manager, there are many other useful objects available in a project. They can be defined and managed through the tools accessible in the > Managers menu.
The **Data Structure Manager** allows you to define and configure data structures. A *data structure* represents a structured data type (usually called a *structure* or *record* in programming languages) composed of multiple fields which can again be data structures.

The **Communication Driver Manager** allows you to configure the settings of the available communication drivers (i.e. the drivers available with **Reliance 4** that provide communication with I/O devices).

The **Recipe Manager** allows you to define and configure recipes. A *recipe* represents a group of tags. It is used to store real-time values of the tags to a disk file. A stored recipe can later be loaded from the file and transferred to the respective devices.

The **Data Table Manager** allows you to define and configure data tables. A *data table* represents a physical table stored in a database. Within a data table, you define fields linked to tags whose data should be logged. The fields represent the physical table's columns. By defining a data table, you enable the runtime software to access (read and/or write) historical data.
The **Trend Manager** allows you to define and configure trends. A *trend* is used for graphic presentation of the data stored in a database(s) (i.e. historical data) in the form of a trend chart. Trends can be displayed at runtime via the trend viewer.

The **Real-Time Trend Manager** allows you to define and configure real-time trends. A *real-time trend* is used for graphic presentation of a sequence of the most recent values of the selected tags in the form of a trend chart. The values (time samples) are only stored in the memory, not in a database. A real-time trend can be displayed at runtime by a Real-Time Trend component placed into a visualization window.

The **Report Manager** allows you to define and configure reports. A *report* is used for graphic presentation of the data stored in a database (i.e. historical data) in a tabular format. Reports can be displayed, printed and exported at runtime via the report viewer.

The **Custom Report Manager** allows you to define and configure custom reports. A *custom report* is used for graphic presentation of real-time values of the selected tags in a user-defined format. Custom reports can be displayed, printed and exported at runtime via the custom report viewer. When defining a new custom report, it is necessary to prepare a template in text, HTML or FastReport format and save it to a disk file. The template may also include graphic elements if using HTML or FastReport format.

The **String Manager** allows you to manage text strings used in a project. A single string can be used on multiple places in a project. If a string is modified via the **String Manager**, all occurrences are updated immediately. If a project uses multiple languages, the **String Manager** allows you to translate all strings used in the project into all the languages.

The **Picture Manager** allows you to manage pictures used in a project. Pictures can be imported in different formats from any location on the computer. Once a picture has been imported, it can be displayed on any place in the visualization through the appropriate component (graphical object). **Reliance 4** ships with a graphics library containing a lot of useful graphics to be used in visualization projects.

The **Action Manager** allows you to define and configure actions. An *action* represents an operation such as activating a window, showing a trend, logging a user off the program, terminating the program. An action can be run e.g. by clicking on a component.

The **Script Manager** allows you to define and configure scripts. The source code of a *script* must be written in VBScript. Scripts enable you to implement custom logic into a project.

The **User Manager** allows you to define and configure users. A *user* represents an operator that can log on to a visualization application during runtime. A user can be assigned a set of access rights and security restrictions. Various functions of a project can be made accessible only to users with specific access rights.
3.5 Project Structure Manager – Control areas and Computers

The Project Structure Manager command is located on the > Managers menu. The Project Structure Manager is a tool designed for defining the structure of an entire visualization project. It enables you to define the structure consisting of control areas, computers, server connection groups, server connections, devices, data tables, and other objects, so that it corresponds to a real plant site.

A Control area is an independent unit representing a separate locality, where one or more computers designed for running a project are located. The typical example of a control area is a control room.

A Computer represents an actual computer on which the project will be running at the end user site.

A project always comprises at least one Control area which in turn comprises at least one Computer.

The objects defined through other managers, such as devices, data tables, trends and reports, can be made accessible to a computer by connecting them to the computer, i.e. adding links to the objects to the computer's appropriate folder. By connecting an object to a computer, you define that the object should be accessible in the project running on the computer.

For example, if a computer is to read data from a device (e.g. a PLC), you have to connect the device (previously defined via the Device Manager) to the computer. To do it, select the Devices folder of the computer in the tree diagram and choose the Connect objects command from the toolbar or the Connect devices command from the local menu of the tree diagram. Then configure the properties of the device's communication channel (connection type, communication options, etc.). The same applies to other previously defined objects. For example, if a computer is to log data to a data table, you have to connect the table (previously defined via the Data Table Manager) to the computer.
3.6 Designing windows

A project usually contains one or more windows (i.e. visualization windows). A window is intended to become a custom graphical view of an industrial process. At runtime, a window becomes part of the user interface of the runtime software which is used by the operator to monitor (and control) the visualized process.

To manage windows, use the **Window Manager** which can be shown/hidden from the > View menu.
To view or edit the properties of a window, choose the **Window Properties** command from the popup menu of the window or double-click the window. This will bring up the **Window Properties** dialog box.

To configure the properties of multiple windows at the same time, select the windows in the **Window Manager** and edit their properties through the **Component Manager**. It can be shown/hidden from the > View menu.

When designing a window, add individual components from the **Component Palette** to the window. A component selected on the palette by clicking the left mouse button may be placed into a window either with its default size (by clicking on the window area), or with the size defined by dragging the mouse inside the window area (before releasing the mouse button).

To add multiple components of the same type, press the **Shift** key while selecting the component on the palette.

To change the position or size of components or component groups, edit functions may also be used – e.g. centering, alignment, changing the Z order, modification of height and width, transformation, etc. The **Undo** and **Redo** commands allow you to undo and redo up to the last 100 edit actions.

The last step when designing a window is configuring the properties of the components, which affects their appearance and behavior. To configure the properties of a single component, use the component’s property editor (double-click the component or choose the **Component Properties** command from the component’s popup menu). The properties of individual components differ depending on their type.

To configure the properties of multiple components at the same time, select the components and edit their properties through the **Component Manager**.
Some components can display a picture or multiple pictures. If you want to use a picture in a project, it must be first imported to a picture database of the project via the Picture Manager. It can be opened from the > Managers menu.

![Picture Manager](image)

**3.7 Running a project**

Before running a project for the first time, you should view the options (and change them if needed) available in the Project Options dialog box under the Runtime item. To view these options, choose the > Project > Options command.

To run the project, choose the > Project > Run command.
This command launches the selected runtime software (by default *Reliance 4 Control* or *Reliance 4 Control Server*) which loads and runs the project. By default, the runtime software's main window containing the visualization is maximized to full screen mode.

The exit the runtime software, choose the > *File* > *Exit* command or use the ALT + F4 key shortcut.
4 Example

4.1 Creating a new project

1. Choose the > File > New Project command.
2. In the Create New Project Wizard, choose a name for the new project (Tip: keep the defaults).
3. In the remaining steps of the wizard, keep the defaults.
4. Complete the wizard.
5. In the Create New Window Wizard, choose a name and title for the new window (Tip: keep the defaults).
6. In the remaining steps of the wizard, keep the defaults.
7. Complete the wizard.

4.2 Adding devices and tags

1. Choose the > Managers > Device Manager command from the main menu.
2. Choose the New Device command from the toolbar and choose the item named Virtual from the Select Device Type dialog box to add a virtual device.
3. Optionally, change the name of the device on the Basic page (Tip: keep the default name Virtual1).
4. Select the Tags folder of the new device in the tree diagram.
5. Add a new tag by invoking the New Tag command from the toolbar or pressing the Insert key on the keyboard.
6. Configure the new tag’s properties on the Basic page as follows: Name = Required_Temperature, Units = °C, Tag data type = Float.
7. Configure the tag’s properties on the Advanced page as follows: Dec. place count = 1.
8. Close the Device Manager by clicking on the OK button.
9. In the dialog box that appears, choose Yes. This will bring up the Project Structure Manager and automatically connect the new device to the computer defined in the project.
10. Close the Project Structure Manager by clicking on the OK button.
4.3 Component position and properties

1. In the **Component Palette**, select the *Display* component (by default, the first from the left on the palette) by clicking on the respective icon.

2. Add a new *Display* component to the window by clicking on the window area.

3. Bring up the component’s property editor (the **Display Properties** dialog box) by double-clicking the component.

4. On the **Functions** page in the **Link to tag** edit box, define a link to the tag `Virtual1. Required_Temperature`.

5. On the **Eng. units** page, activate (check) the **Visible** property.

6. Close the property editor by clicking the **OK** button.

7. From the **Component palette**, add new *Button* component (by default, the second from the left on the palette) to the window.

8. Bring up the component’s property editor (the **Button Properties** dialog box) by double-clicking the component.

9. On the **Functions** page in the **Link to tag** edit box, define a link to the tag `Virtual1. Required_Temperature`.

10. On the **States/State 0** page in the **Text** edit box, change text to "Change Value".

11. Close the property editor by clicking the **OK** button.

12. Widen the button so that the whole text is visible on it (**Tip**: to slightly resize the components currently selected in a window, press and hold down the Shift key while pressing the arrow key representing the direction in which you want to resize the components).
4.4 Testing the project

1. Choose the > Project > Run command to run the project.
2. Click the Button component to bring up the Enter Value for Tag dialog box.
3. Enter a new value and close the dialog box by clicking the OK button.
4. The new value should immediately be shown by the Display component.